Как создать внешний отчет в Управление торговлей 11 (УТ) и Рознице 2 (Управляемые формы)

Для создания внешних отчетов, нужно уметь создавать отчеты на СКД (Схемы компоновки данных).

Чтобы создать отчет заходим в конфигуратор, и создаем новый внешний отчет. Настраиваем СКД для отчета. При создание СКД указывайте правильное название вариантов отчета, т.е. если вы назовете вариант «Основной» то и отчет в программе будет называться «Основной»

В модуле объекта размещаем текст

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = Новый Структура;
МассивНазначений = Новый Массив;
МассивНазначений.Добавить(«»);

ИмяОтчета Метаданные().Представление();

ПараметрыРегистрации.Вставить(«Вид»«ДополнительныйОтчет»);
ПараметрыРегистрации.Вставить(«Назначение»МассивНазначений);
ПараметрыРегистрации.Вставить(«Наименование»ИмяОтчета);
ПараметрыРегистрации.Вставить(«Версия»«1.0»);
ПараметрыРегистрации.Вставить(«БезопасныйРежим», Истина);
ПараметрыРегистрации.Вставить(«Информация»«Дополнительный отчет»);

ТаблицаКоманд ПолучитьТаблицуКоманд();

ДобавитьКоманду(ТаблицаКомандИмяОтчетаМетаданные().ПолноеИмя(), «ОткрытиеФормы», Истина);

ПараметрыРегистрации.Вставить(«Команды»ТаблицаКоманд);

Возврат ПараметрыРегистрации;
КонецФункции

Функция ПолучитьТаблицуКоманд()
Команды = Новый ТаблицаЗначений;
Команды.Колонки.Добавить(«Представление», Новый ОписаниеТипов(«Строка»));
Команды.Колонки.Добавить(«Идентификатор», Новый ОписаниеТипов(«Строка»));
Команды.Колонки.Добавить(«Использование», Новый ОписаниеТипов(«Строка»));
Команды.Колонки.Добавить(«ПоказыватьОповещение», Новый ОписаниеТипов(«Булево»));
Команды.Колонки.Добавить(«Модификатор», Новый ОписаниеТипов(«Строка»));
Возврат 
Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКомандПредставлениеИдентификаторИспользованиеПоказыватьОповещение = Ложь,Модификатор «»)
НоваяКоманда ТаблицаКоманд.Добавить();
НоваяКоманда.Представление Представление;
НоваяКоманда.Идентификатор Идентификатор;
НоваяКоманда.Использование Использование;
НоваяКоманда.ПоказыватьОповещение ПоказыватьОповещение;
НоваяКоманда.Модификатор Модификатор;
КонецПроцедуры

Сохраняем отчет.

Открываем 1с в режиме предприятия «Администрирование» — «Печатные формы, отчеты и обработки» — «Дополнительные отчеты и обработки»

Создаем новую запись, программа предложит выбрать файл, указываем наш внешний отчет, нажимаем кнопку сохранить (или Ctrl + S). На закладке «Варианты отчета» нажимаем кнопку «Разместить в разделах…» выбираем разделы и нажимаем «Разместить».

Проверяем результат.

2 комментария

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Adblock detector